Home » 开发工具 » FlashDevelop » 在FlashDevelop里使用1.7版本的的TortoiseSVN

在FlashDevelop里使用1.7版本的的TortoiseSVN

发表评论 阅读评论

前几天更新TortoiseSVN到1.7版本后发现FD(FlashDevelop)里不能使用svn了,在项目面板里的所有文件及文件夹都不能正确显示svn状态了,清一色都显示为未添加版本控制的状态图标,并且在FD的输出面板(output Panel)里输出:

Unable to get repository status: (1)

不能获取仓库状态,之所以会这样是因为TortoiseSVN1.7和1.6的文件格式不同。
FD默认使用的是1.6版本的SlikSVN(Slik Subversion),和TortoiseSVN一样都是svn工具,但不是同一个.我之前一直以为是同一个,以为FlashDevelop为了方便,把TortoiseSVN也包进tools目录了。
TortoiseSVN更新到1.7版本,使用了新格式,FD使用SlikSVN 1.6 将不能做任何操作和显示正确的状态,必须也更新该命令行工具到 SlikSVN 1.7 以便兼容新格式。
实际上FD兼容任何的svn命令行工具。http://subversion.apache.org/packages.html

配置FD使用SlikSVN

在FD的【工具菜单(Tools)】里选择【程序设置子菜单(Program Settings…)】,打开【设置面板(Settings)】,在左边选择【源代码控制选项(SourceControl)】,在右边找到【SVN】,进行以下设置.

  • Enable SVN:设置为true
  • SVN Path: 设置为svn.exe的路径(包含svn.exe), {FlashDevelop安装目录}Toolssliksvnbinsvn.exe为1.6版本,1.7版本请到上面下载并安装后,将svn.exe路径写在这里.
  • TortoiseSVN Proc Path: 设置为{TortoiseSVN安装目录}binTortoiseProc.exe

设置完成了,重启机器后就能在FD里使用svn了.
fd-with-svn.jpg

  1. | |

    我只在玩sae时用过TortoiseSVN。

  1. 本文目前尚无任何 trackbacks 和 pingbacks.
回到顶部